
 

 

 
 

Quick Start Guide 
 

 

 

 

 

 

 

 

 

 

© Copyright 2011 Rapid Insight® Inc.  All Rights Reserved



 

REVISED: 2/22/11 jaf 

2 

 

 

 
 

 

 

 

Rapid Insight® Veera™ - Quick Start Guide 

QUICK REFERENCE – Workspace Tab 
 

  

 

 

 

 

JOBS 
Jobs are user-created processes that pull data from one or more sources (“Connections”), 
manipulate that data with various tools (“Tasks”), and produce one or more outputs as files 
and/or reports (“Runables”). Jobs are managed (created, deleted, organized, copied, exported, 
imported, named, opened, run, scheduled) from the Workspace tab. 

 

DATA CONNECTIONS  
These point to where data may be located (folders, servers) on the local computer or network. 
Connections are automatically grouped by the data source file type (Excel, Text, Access, SQL, etc).   

 

DATA TABLES  
Tables name specific data files or parts of files (individual worksheets 
within an Excel workbook) that both match the location and data 
source type of the Connection. Tables appear beneath Connections. 

ACTIVE PROCESSES  
The Active Processes section shows which jobs are currently running and 
their elapsed time. If no jobs are running, this space remains blank. 

 

WORKSPACE TAB 
Where users organize and manage the data processes (“Jobs”) they’ve created, view the data 
sources they’ve identified (“Data Connections”), and see which jobs may be currently running 
(“Active Processes”). If closed, it can be reopened from the toolbar menu item “Window”. 

MAIN MENU 
Toolbar menu options change when the Workspace tab is selected. See Appendix B. 
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QUICK REFERENCE – Job Tab 
  

 

 

 

 

JOB WORKSPACE TOOLS 
Provides tools to run, pause, stop, validate and save 
the job. Additional tools aid in job construction 
including add node connections, set run order, undo, 
redo, and add / read notes 

 

CONNECTIONS  
Connections indentify where 
data can be found (folders, 
servers). Tables appear 
beneath Connections and 
name specific data files or 
parts of files (worksheets in 
an Excel workbook) in that 
location of that type. Every 
job must include at least one 
before it can be run. 

RUNABLE  
Runables provide destinations 
for data output by a job. These 
include files and/or reports. 
Every job must include at least 
one before it can be run. 

TASKS 
Tasks are tools used to 
manipulate data as part of a 
process “Job”. 

 

JOB WORKSPACE 
Where users build and edit Jobs. 
Connections, Tasks and Runables 
(“nodes”) are dragged and 
dropped into this space, then 
connected together (using the 
“Node Connection” workspace 
tool) in a process order.  
Individual nodes are configured 
by double-clicking.  

MAIN MENU 
Toolbar menu options change 
when the Job tab is selected. 
See Appendix B. 

JOB TAB 
Users build and edit the 
selected job here. Several 
Job tabs may be open at a 
time. 
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CREATING YOUR FIRST JOB IN VEERA 

1. Start a new job 
• Right-click in the Workspace > Jobs section and select New Job. 

• Click on the New Job tab 

2. Create a connection to your data 
• Create a Data Connection to the data folder or database 

i. Right-click Connections and select ‘New Connection’ 

ii. Enter a connection name, data source type and other connection details 

iii. Save the connections settings 

• Then select specific database tables or data files using the Select Tables menu option. 

i. Right-click the connection just made and choose Select Tables 

ii. Highlight and Select files, worksheets, tables from connection location 

iii. Save the selected tables settings 

3. Add connection, task and output nodes to your job 
• With the mouse, drag the selected node from the lists on the left and drop it into the job. 

4. Connection nodes together to create a process flow 
• Alt-Click on one node, then drag and drop it onto another node. A line will connect the two. 

5. Run your job 
• While on the job tab, click on the Run Job control on the Jobs Toolbar (green arrow), 

6. View the results 
• Right-click on the output file or report and select View Data or View Report. 

7. Save your job 
• Click the blue disk or green checkmark icon on the Job’s tab  
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FREQUENTLY ASKED QUESTIONS ABOUT VEERA 

DATA CONNECTIONS IN VEERA 

HOW DO I TELL VEERA WHERE TO FIND MY DATA? 

Create a Data Connection to the data folder or database 

Right-click Data Connections and select ‘New Connection’ 

Enter a unique Connection Name 

Select a Data Source Type 

Enter the requested information for the Data Source Type  

Save the connection settings 

Then select specific database tables or data files using the Select Tables menu option. 

Right-click the Data Connection and choose Select Tables 

Highlight and Select files, worksheets, tables from connection location 

For Text file data connections, the properties often need to be defined. 

Save the selected tables settings 

WHY CAN’T I SELECT THE DATA FILES I SEE? 
When creating a Data Connection, selecting individual data files is not possible. Connections to 
specific data files are done using the Select Tables menu option. 

WHY CAN’T I SEE THE DATA FILES I KNOW ARE THERE? 
The Select Tables screen will only show and select files that match the Data Connection type (Excel, 
text, Access, etc).  

WHY CAN’T I SEE THE EXCEL FILES I KNOW ARE THERE? 
There are three types of Excel files (XLS, XLSX, XLSB). The Data Connection type must match the file 
type exactly for the files to display in the Select Tables screen. 

WHY CAN’T I SEE THE ACCESS FILES I KNOW ARE THERE? 
There are two types of Access files (MDB, ACCDB). The Data Connection type must match the file 
type exactly for the files to display in the Select Tables screen. 

WHY CAN’T I SAVE THE TEXT FILES I’VE SELECTED AS DATA 
SOURCES? 

Text files must have their properties defined before they can be used as sources of data in Veera. 
Select the file(s) to be used, then click the Properties button beside each to configure. 

HOW DO I ADD A DATA CONNECTION TO A JOB? 
Right-click in the Job’s Connections section and chose the Select Existing menu item. An 
alphabetically list of existing Data Connections and their associated files/tables will be displayed 
from which the desired connections can be chosen. 

CAN I USE DIFFERENT TYPES OF DATA IN THE SAME JOB? ABSOLUTELY! There are no restrictions on the types or number of data sources used by a job. 

CAN I DELETE A TABLE OR DATA CONNECTION? 
YES.  Right-click on the file, table or Data Connection and select Delete or Remove. Note that this will 
not harm the data itself, though it will disable jobs using the deleted connection. 
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MANAGING JOBS IN VEERA 

HOW DO I START A NEW JOB? 
Right-click in the Workspace > Jobs section and select New Job, or  

Select Job > New Job from the main toolbar menu. A tab labeled New Job will open. 

HOW DO I SAVE A JOB? 

Click the blue disk or green checkmark icon on the Job’s tab, or  

Select Job > Save from the main toolbar menu, or 

Select Job > Save As from the main toolbar menu. 

HOW DO I RENAME A JOB? 
Right-click on the entry for the job in the Workspace > Jobs section and select Rename, or  

While viewing the job, select Job > Save As from the main toolbar menu. 

HOW DO I COPY A JOB? 
Right-click on the entry for the job in the Workspace > Jobs section and select Copy Job, or  

While viewing the job, select Job > Save As from the main toolbar menu. 

HOW DO I SHARE A JOB WITH OTHERS? 

Jobs may be exported as .vjf files outside of Veera and imported by other users. To export a job: 

Right-click on the job in the Workspace > Jobs section and select Export, or  

While viewing the job, select Job > Export from the main toolbar menu. 

Select  a location for the .vjf file to be saved 

To import a job (the new job will appear in the Jobs section of the Workspace tab): 

Right-click in the Workspace > Jobs section and select Import Job, or  

Select Job > Import Job from the main toolbar menu and select the .vjf file, or 

Drag and drop the .vjf into the desired folder of the Jobs section of the Workspace tab. 

WHY IS MY IMPORTED JOB NOT WORKING? 

Imported jobs often need to be reconnected to a data source in the new environment. Either… 

Create connections and select files/tables whose names match those in the job, or 

Remove the job’s current connections and use existing connections to replace them. 

HOW DO I CREATE A JOB FOLDER? Right-click on the Jobs label in the Workspace tab and select New Folder 

CAN I CREATE A FOLDER WITHIN A FOLDER? YES.  Right-click on the an existing folder and select New Folder 

HOW DO I PLACE JOBS IN A FOLDER? With the mouse, drag and drop the job onto the destination folder 

HOW DO I SAVE A JOB INTO A SPECIFIC FOLDER? Selecting the destination folder is part of the normal Job Save process 

CAN I MOVE A FOLDER INTO ANOTHER FOLDER? YES. With the mouse, drag and drop the folder onto the destination folder 
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BUILDING JOBS IN VEERA 

HOW DO I ADD NODES TO A JOB? 
Adding connections, tasks and runable outputs to a job is easy.  With the mouse, drag the selected 
node from the lists on the left and drop it into the job. It’s that simple! 

HOW MANY NODES CAN I ADD TO A JOB? There’s no limit to the number of connections, tasks or runables a user can add to a job. 

HOW DO I CONNECT NODES TOGETHER? 

Click the Node Connect Mode control (red boxes) on the Jobs Toolbar. Then click on the node where 
data is coming from. Finally, click on the node where the data is going to. A connecting line will 
appear, joining the two nodes Repeat these two steps to connect additional nodes. Don’t forget to 
click the control again to turn it off. 

Alternately, Alt-Click on the source node, then drag and drop it onto the destination node. A 
connecting line will appear, joining the two nodes 

HOW DO I DELETE A CONNECTION BETWEEN NODES? 

Right-click on the line and select Delete, or  

Click on the line and then click the Delete Selected Items Jobs Toolbar control (red X), or 

Click on the line and select Edit > Delete from the main toolbar menu. 

CAN I RELOCATE A NODE? 
YES. Click, drag and drop the node into its new location. All connections will “rubber band” to 
accommodate the new position. 

CAN I RELOCATE SEVERAL NODES AT ONCE? 
YES. Click into an empty space in the job then, with the mouse button still pressed, drag the mouse. 
All the nodes and connections within the box that is drawn will be highlighted. Release the mouse 
button, then use the keyboard arrow keys to reposition the selected nodes. 

CAN I COPY AN EXISTING NODE? YES. Ctrl-Click on the source node, then drag and drop its copy into the new position.  

CAN I COPY SEVERAL NODES AT ONCE? Not at this time. 

WHY CAN’T MY OUTPUT CREATE A DATABASE TABLE? 
The option that allows this may be turned off. Select Tools > Options from the main toolbar menu. 
Check the box labeled “Allow Create Table in Database” on the General tab, then SAVE. 

HOW DO I ATTACH A NOTE TO A NODE? 

Right-click on the node and select Edit Notes, or 

Click on the node and then click the Edit Notes Jobs Toolbar control (yellow note), or 

Click on the node and then select Job > Edit Notes from the main toolbar menu. 

CAN I ATTACH A NOTE TO THE WHOLE JOB? 

YES. With no node selected: 

Click the Edit Notes Jobs Toolbar control (yellow note), or 

Select Job > Edit Notes from the main toolbar menu. 

CAN I DELETE A NOTE? YES - by opening the note and deleting its contents. 



 

REVISED: 2/22/11 jaf 

8 

 

 

 
 

 

 

 

Rapid Insight® Veera™ - Quick Start Guide 

RUNNING JOBS IN VEERA 

HOW DO I RUN A JOB? 
While on the job tab, click on the Run Job control on the Jobs Toolbar (green arrow), or 

Right-click on the job in the Workspace > Jobs section and select Run. 

CAN I RUN JUST ONE PART OF A JOB? YES. Right-click on the output node to run individually and select Run This Output Only. 

CAN I VIEW THE DATA COMING OUT OF A SPECIFIC NODE? YES. Right-click on the node and select Preview Data. 

HOW MANY JOBS CAN I RUN AT THE SAME TIME? There’s no limit to the number of jobs that can be running at the same time. 

CAN I SCHEDULE A JOB TO RUN? 
YES. While on the job tab, select Schedule > Job from the main toolbar menu, or  

Right-click on the job in the Workspace > Jobs section and select Schedule. 

MUST VEERA BE OPEN FOR A SCHEDULED JOB TO RUN? SOMETIMES – Yes when using the Desktop version, NO when using the Client/Server version  

CAN VEERA NOTIFY ME WHEN A SCHEDULED JOB RUNS? 

YES. Reports can be set up to auto-email themselves when created. To configure this feature: 

Select Tools > Options from the main toolbar menu  

Enter local email service setting on the SMTP Information and Distribution Lists tabs 

To use the feature in a particular report node in a job: 

Open the report setup window and check Enable Distribution 

Click the Distribution Setup button and select the recipient(s) 

GENERAL QUESTIONS ABOUT VEERA 

HOW DO I UPDATE MY PROGRAM? Select Help > Updates from the main toolbar menu  

WHERE DID MY WORKSPACE TAB GO? 
The Workspace tab may have been inadvertently closed. Select Window > Workplace from the main 
toolbar menu to reopen the tab. 

HOW MANY JOBS CAN BE OPEN AT THE SAME TIME? There’s no limit to the number of jobs that can be open at the same time. 

WHERE CAN I FIND MY ERROR LOG FILES? 
Select Help > Log Files from the main toolbar menu. Logs may be view and/or emailed to Rapid 
Insight from this location. 
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TRANSFORM TASK FUNCTIONS SUMMARY 

Function Operators 
Because functions have such a high priority they almost always require their parameters be in parentheses to achieve the expected/correct result. 

 "ABS [A]" is the same as "ABS ([A])", but "ABS [A]*[B]" is not "ABS ( [A]*[B] )", but is "ABS([A])*[B]" 

 

 

PRECEDENCE SYMBOL TYPE OF OPERATION ASSOCIATIVELY 

1 () Expression Left to right 

2  Scalar Functions Left to right 

3 -    ~   ! Unary Right to left 

4 *  /  %   ** Multiplicative Left to right 

5 +  - Additive Left to right 

6 <<   >> Bitwise shift Left to right 

7 <   >  <=   >= Relational Left to right 

8 =   ==  <>  !=   IS Equality Left to right 

9 & Bitwise-AND Left to right 

10 ^ Bitwise-exclusive-OR Left to right 

11 | Bitwise-OR (inclusive) Left to right 

12 BETWEEN Logical-BETWEEN Left to right 

13 IN Logical-IN Left to right 

14 LIKE Logical-LIKE Left to right 

15 &&   AND Logical-AND Left to right 

16 || OR Logical-OR Left to right 

17 ?? Null-Coalescing Left to right 

18 ?: Inline-If/Then Left to right 

19 , List Left to right 
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Function Descriptions 
 

Abs ABS(  ) Returns the absolute, positive value of the given numeric expression 
ACos ACOS(  ) Returns the angle, in radians, whose cosine is the given real expression 
ASin ASIN(  ) Returns the angle, in radians, whose sine is the given real expression 
ATan ATAN(  ) Returns the angle in radians whose tangent is the given real expression 
ATn2 ATN2( #y, #x ) Returns the angle, in radians, whose tangent is the quotient (Y/X) of given real expressions 
Ceiling CEILING(  ) Returns the smallest integer, greater than, or equal to, the given numeric expression 
Char CHAR(  ) A string function that converts an int ASCII code to a character 
CharIndex CHARINDEX( 'string',  ) Returns the starting position of the specified expression in a character string.  Returns -1 if not found 
Contains CONTAINS( 'string',  ) Returns 1 if the specified expression is in the character string, otherwise returns 0 
Cos COS(  ) Returns the trigonometric cosine of the given angle (in radians) in the given expression 
Cot COT(  ) Returns the trigonometric cotangent of the specified angle (in radians) in the given real expression 
Date DATE( '' ) Converts a string to a date 
DateStr DATESTR(  ) Convert a date to a string 
DateStr DATESTR( , 'd' ) Format a date as a string 
Day DAY(  ) Returns an integer representing the day date-part of the specified date (1-31) 
DayOfWeek DAYOFWEEK(  ) Returns a string representing the day date-part of the specified date (Sunday, Monday, etc.) 
DayOfWeekN DAYOFWEEKN(  ) Returns an integer representing the day date-part of the specified date (1-7) 
DayOfYear DAYOFYEAR(  ) Returns an integer representing the day date-part of the specified date (1-366) 
DaysBetween DAYSBETWEEN( , date ) Returns an integer representing the #of days between 2 dates 
Degrees DEGREES(  ) Given an angle in radians, returns the corresponding angle in degrees 
DistanceBetween DISTANCEBETWEEN( , 

zipcode ) 
Returns a real representing the # of miles between 2 zipcodes 

DistanceBetweenLatLon DISTANCEBETWEENLATLON( 
, lon1, lat2, lon2 ) 

Returns a real representing the # of miles between 2 Latitude/Longitude coordinate pairs. 

DistanceBetweenMGRS DISTANCEBETWEENMGRS( , 
mgrsCoord ) 

Returns a integer representing the # of meters between 2 MGRS coordinates (in same GZD). 

DistanceFrom DISTANCEFROM( , 'zipcode' 
) 

Returns a real representing the #of miles between a zipcode and a constant zip code 

DistanceFromLatLon DISTANCEFROMLATLON( , 
varLon1, constLat2, 
constLon2 ) 

Returns a real representing the # of miles between a variable and a constant Latitude/Longitude coordinate 
pair. 
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DistanceFromMGRS DISTANCEFROMMGRS( , 
'mgrsCoord' ) 

Returns a real representing the # of meters between a MGRS coordinate and a constant MGRS coordinate 
(in same GZD). 

Exp EXP(  ) Returns the exponential value of the given real expression 
Floor FLOOR(  ) Returns the largest integer less than or equal to the given numeric expression 
Greatest GREATEST( , expr, ... ) Returns the largest value in a list of 2 or more values 
Hour HOUR(  ) Returns an integer that represents the hour part of a specified datetime 
HoursBetween HOURSBETWEEN( , date ) Returns an integer representing the # of hours between 2 dates 
If IF( , trueValue, falseValue ) Tests an expression result, returns one value if TRUE and another value if FALSE 
IsNull ISNULL( , 

replacement_value ) 
Tests if an expression result is null, returns the result if it is not null, otherwise a replacement value 

Is Null ( IS NULL) Tests if an expression result is null, evaluates to Boolean 
Least LEAST( , expr, ... ) Returns the smallest value in a list of 2 or more values 
Left LEFT( , #len ) Returns the left part of a string the specified number of characters in length 
Len LEN(  ) Returns the number of characters of the given string, excluding trailing blanks 
Log LOG(  ) Returns the natural logarithm of the given real expression 
Log10 LOG10(  ) Returns the base-10 logarithm of the given real expression 
Lower LOWER(  ) Returns a character expression after converting uppercase character data to lowercase 
LTrim LTRIM(  ) Returns a character expression after removing leading blanks 
MetersToMiles METERSTOMILES(  ) Returns the real numbers of miles equivalent to the specified number of meters. 
Minute MINUTE(  ) Returns an integer that represents the hour part of a specified datetime 
MinutesBetween MINUTESBETWEEN( , date ) Returns an integer representing the # of minutes between 2 dates 
Month MONTH(  ) Returns an integer that represents the month part of a specified date (1-12) 
MonthOfYear MONTHOFYEAR(  ) Returns a string that represents the month part of a specified date (January, February, etc.) 
MonthsBetween MONTHSBETWEEN( , date ) Returns an integer representing the # of months between 2 dates 
Now NOW() Returns the current date/time 
NullIf NULLIF( , expr ) Returns a null if two expression are equivalent 
Num NUM(  ) Returns numeric data converted from character data 
PadLeft PADLEFT( , #len, ' ' ) Returns a string padded on the left with specified character to the specified length 
PadRight PADRIGHT( , #len, ' ' ) Returns a string padded on the right with specified character to the specified length 
PI PI() Returns the constant value of PI (3.14…) 
Power POWER( , #pow ) Returns the value of the given expression to the specified power 
Quarter QUARTER(  ) Returns an integer representing the 'Quarter' specified date falls between 
Radians RADIANS(  ) Returns radians when a numeric expression, in degrees, is entered 
Random RANDOM() Returns a random number between 0.0 and 1.0 



 

REVISED: 2/22/11 jaf 

1
 

 

 

 
 

 

 

 

Rapid Insight® Veera™ - Quick Start Guide 

Replace REPLACE( , 'find', 'new' ) Replaces all occurrences of the first string expression with the second string expression 
RemoveLeft REMOVELEFT( , #cnt ) Removes specified number of characters from left end of string expression 
RemoveRight REMOVERIGHT( , #cnt ) Removes specified number of characters from right end of string expression 
Reverse REVERSE(  ) Returns the reverse of a character expression 
Right RIGHT( , #len ) Returns the right part of a string the specified number of characters in length 
Round ROUND(  ) Round value to the nearest integer value 
RTrim RTRIM(  ) Returns a character string after truncating all trailing blanks 
Second SECOND(  ) Returns an integer that represents the second part of a specified datetime 
SecondsBetween SECONDSBETWEEN( , date ) Returns an integer representing the # of seconds between 2 dates 
Sign SIGN(  ) Returns the positive (+1), zero (0), or negative (-1) sign of the given expression 
Sin SIN(  ) Returns the trigonometric sine of the given angle (in radians) in an approximate numeric (real) expression 
Space SPACE(  ) Returns a string of repeated spaces 
Square SQUARE(  ) Returns the square of a given expression 
Sqrt SQRT(  ) Returns the square root of the given expression 
Str STR(  ) Returns the character data converted from numeric data 
Stuff STUFF( , #start, #len, 'new' ) Deletes a specified length of characters and inserts another set of characters at a specified starting point 
SubField SUBFIELD( , #fieldNum ) Returns the Nth 'sub-field' from a string where the fields are delimited by commas 
SubField SUBFIELD( ,#fieldNum, ',' ) Returns the Nth 'sub-field' from a string where the fields are delimited by the specified delimiter (default is 

comma) 
SubString SUBSTRING( , #start ) Returns part of a string beginning at the specified start position to the end of the string 
SubString SUBSTRING( , #start, #len ) Returns part of a string beginning at the specified start position and continuing for the specified length 
Tan TAN(  ) Returns the tangent of the input expression 
Today TODAY() Returns the current date 
Upper UPPER(  ) Returns a character expression with lowercase character data converted to uppercase 
Week WEEK(  ) Returns an integer expression representing the week that the specified date falls in (1-53) 
Weekday WEEKDAY(  ) Returns 'Weekday' or 'Weekend' 
WorkdaysBetween WORKDAYSBETWEEN( , 

date ) 
Returns an integer representing the # of workdays between 2 dates 

Year YEAR(  ) Returns an integer that represents the year part of a specified date 
YearsBetween YEARSBETWEEN( , date  ) Returns an integer representing the # of years between 2 dates 
ZipCode ZIPCODE(  ) Returns a 5 character zipcode converted from string or numeric data.  Illegal values are output as text 
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Special Parameters 
This section documents unique parameters that do not fit neatly into other categories yet expand the user’s abilities.  

 

SYMBOL TYPE BEHAVIOR DESCRIPTION 

* Parameter Wildcard 

When an asterisk is used as a formula parameter, it acts as a wildcard.  

COMBINE INPUTS Table Pattern Example: 

Enrollment Data*.* 

Selects all files, regardless of type, that start with the characters ”Enrollment Data”. 

Regex: Functional 
Parameter Wildcard 

When the function is used as a formula parameter, it acts as a wildcard with features beyond those of an asterisk. 

COMBINE INPUTS Table Pattern Example: 

Regex:CX..\.xls.*\.*$ 

Selects all worksheets from all Excel (.xls) files that start with the characters ”CX” followed by exactly two 
characters. 

[_] Parameter Lag 

When an underscore in square brackets is used as a formula parameter, it applies the value of the previous record. 
Typically used in conjunction with the ISNULL function to avoid problems with the first record in the dataset.  

TRANSFORM Multi-variable Example:  

IF( [_]  IS NULL, 100, [_] + 1 ) 

Creates an incrementing series in the new column starting at 100. 

 

KEYBOARD SHORTCUTS 

USE ACTION 

COPY AN EXISTING NODE Ctrl-Click on the source node, then drag and drop the copy into the new position 

CONNECT TWO NODES Alt-Click on the source node, then drag and drop it onto the destination node 

CONNECT SEVERAL NODES AT THE SAME TIME Alt-Click in empty space, drawing a box around several nodes in a line. Release mouse to connect. 

 

CONTACT US 
For any issues/questions about Rapid Insight® Veera™, please send an email to RI Support at support@rapidinsightinc.com 

mailto:support@rapidinsightinc.com�
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